EXCEL – funkcje, przykłady

 

Funkcja JEŻELI

Zwraca jedną wartość, jeśli podany argument zostanie oszacowany jako PRAWDA, albo inną wartość, jeśli argument zostanie oszacowany jako FAŁSZ.

Funkcję JEŻELI należy stosować do przeprowadzania testów logicznych na wartościach i formułach.

Składnia

JEŻELI(test_logiczny; wartość_jeżeli_prawda; wartość_jeżeli_fałsz)

JEŻELI(test_logiczny; [wartość_jeżeli_prawda]; [wartość_jeżeli_fałsz])

 

test_logiczny jest dowolną wartością lub wyrażeniem, który jako rezultat daje wartość PRAWDA lub FAŁSZ

- sprawdzany czy jest to PRAWDA czy FAŁSZ

JEŻELI(test_logiczny; [wartość_jeżeli_prawda]; [wartość_jeżeli_fałsz])

Składnia funkcji JEŻELI obejmuje następujące argumenty (argument: Wartość, która dostarcza informacji akcji, zdarzeniu, metodzie, właściwości, funkcji lub procedurze.):

·                     test_logiczny Argument wymagany.
Dowolna wartość lub wyrażenie, które można przyjmować wartości PRAWDA lub FAŁSZ.
Na przykład A10=100 to wyrażenie logiczne.
Jeśli wartość umieszczona w komórce A10 jest równa 100, wyrażenie będzie miało wartość PRAWDA.
W przeciwnym wypadku wyrażenie będzie miało wartość FAŁSZ.
Argument ten może zawierać dowolny operator obliczeń porównawczych.

·                     wartość_jeżeli_prawda Argument opcjonalny.
Wartość zwracana, gdy argument test_logiczny ma wartość PRAWDA.
Jeśli na przykład ten argument jest ciągiem tekstowym „W ramach budżetu”, a argument test_logiczny ma wartość PRAWDA, to funkcja JEŻELI zwróci tekst „W ramach budżetu”.
Jeśli argument test_logiczny ma wartość PRAWDA, a argument wartość_jeżeli_prawda zostanie pominięty (to znaczy po argumencie test_logiczny jest jedynie średnik), to funkcja JEŻELI zwróci wartość 0 (zero).
Aby wyświetlić wyraz PRAWDA, jako argumentu wartość_jeżeli_prawda należy użyć wartości logicznej PRAWDA.

·                     wartość_jeżeli_fałsz Argument opcjonalny. Wartość zwracana, gdy argument test_logiczny ma wartość FAŁSZ.
Jeśli na przykład ten argument jest ciągiem tekstowym „Budżet przekroczony”, a argument test_logiczny ma wartość FAŁSZ, funkcja JEŻELI zwróci tekst „Budżet przekroczony”.
Jeżeli argument test_logiczny ma wartość FAŁSZ, a argument wartość_jeżeli_fałsz zostanie pominięty (to znaczy nie ma średnika po argumencie wartość_jeżeli_prawda), to funkcja JEŻELI zwróci wartość logiczną FAŁSZ.
Jeżeli argument test_logiczny ma wartość FAŁSZ, a argument wartość_jeżeli_fałsz zostanie pominięty (to znaczy w funkcji JEŻELI nie ma średnika po argumencie wartość_jeżeli_prawda), to funkcja JEŻELI zwróci wartość 0 (zero

 

Przykład tabeli na obliczenie azymutów boków ciągu poligonowego  ze współrzędnych

 

 

Jeśli azymut w stopniach, wyznaczony z funkcji ATAN2(dx;dy) jest < 0 to dodaje się 360stopni.

Jeżeli DX =0 to za DX podstawia się 0,000000001

 



Przykłady funkcji JEŻELI:


= JEŻELI(B2<1000;B2+B2*B$1;0)
Jeżeli B2 < 1000 to wyświetlenie wartości B2+B2*B$1. W innym przypadku wyświetlone 0.

=JEZELI(ORAZ(B2<1000;B2<>0);B2+B2*B$1;0)

=JEŻELI(A2<=100;"W ramach budżetu";"Budżet przekroczony")
Jeśli liczba w A2 jest mniejsza niż lub równa 100, użycie formuły powoduje wyświetlenie tekstu "W ramach budżetu”.
W innym przypadku wyświetlany jest tekst "Budżet przekroczony" (W ramach budżetu).

=JEŻELI(A2=100;SUMA(B5:B15);"")
Jeśli liczba w A2 jest równa 100, obliczany jest zakres B5:B15. W innym przypadku zwracany jest pusty tekst ("") ()

 

 

Funkcja SUMA.JEŻELI

 

Dodaje komórki spełniające zadane kryterium.

Oblicza sumę dla tych wartości zakresu które spełniają określony warunek - dodaje komórki określone przez podane kryteria.

 

Składnia: SUMA.JEŻELI ( zakres; kryteria; suma_zakres )

SUMA.JEŻELI(zakres; kryteria; [suma_zakres])

 

Zakres to zakres komórek, które należy oszacować - zakres komórek, do którego będzie zastosowane kryterium wyboru.

Kryteria to kryteria mające postać liczby, wyrażenia lub tekstu określającego, które komórki będą dodawane.

Argument kryteria określa kryterium, którego spełnienie lub niespełnienie włącza lub wyłącza komórkę z operacji sumowania.

Na przykład kryteria mogą być wyrażane jako 32, „32”, „>32”, „jabłka”.

Suma_zakres to rzeczywiste komórki wyznaczone do zsumowania.

 

 

Przykład 1:

Zestawienie produkcji.

 

W zakładzie pracują zarówno mężczyźni, jak i kobiety.

Chcąc dowiedzieć się, ile w danym miesiącu wyprodukowały kobiety, a ile mężczyźni, sumujemy osobno produkcję mężczyzn i produkcję kobiet,
korzystając z wyróżnika, jakim jest zaznaczona w osobnej kolumnie płeć pracownika.

SUMA.JEŻELI(B6:B15;"K";C6:C15) - z zakresu komórek B15:B24 określających płeć wybierane są te komórki, które spełniają kryterium K,
po czym sumowane są odpowiadające im wartości produkcji zapisane w zakresie komórek C15:C24 i wynik jest wstawiany w oddzielnej komórce

SUMA.JEŻELI(B6:B15;"M";C6:C15) - z zakresu komórek B15:B24 określających płeć wybierane są te komórki, które spełniają kryterium M,
po czym sumowane są odpowiadające im wartości produkcji zapisane w zakresie komórek C15:C24 i wynik jest wstawiany w oddzielnej komórce

 

Przykład 2

=SUMA.JEŻELI(C6:C15;">100")

z zakresu komórek od C6 do C15 podsumowane zostaną tylko te komórki, których wartość jest większa od 100.

 

 

Przykład 3 - faktura:

Zestawienia sumowe dla różnych stawek VAT: 22%, 7%, 0, zw - zwolnione

 

Np. suma netto dla VAT = 22%

H19 =SUMA.JEŻELI($I$24:$I$30;$I32;H$24:H$30)

gdzie I24-I32 - zakres, w którym występuje stawka VAT 22% (zakres)

I32 - stawka VAT 32% (kryterium)

H24 -H30 - zakres sumowania (suma_zakres)

Suma.jeżeli

 

 

Przykład: JEŻELI, SUMA.JEŻELI

 

 

 

 

Funkcja PMT

Oblicza spłatę pożyczki przy założeniu stałych, okresowych płatności i stałej stopy oprocentowania.

 

PMT(stopa;liczba_rat;wa;wp;typ)

 

Np.

PMT(8%/12; 10; 10000; 0; 1) lub

PMT(8%/12; 10; 10000; 0; 0)

 

Dokładniejszy opis argumentów funkcji PMT znajduje się w opisie funkcji PV.

 

Należy się upewnić, czy dobrze została zrozumiana treść dotycząca argumentów stopa i liczba_rat.
Jeśli dokonuje się spłat miesięcznych pożyczki czteroletniej, oprocentowanej na 12% rocznie, należy użyć wartości 12%/12 dla argumentu stopa i 4*12 dla argumentu liczba_rat.
Jeśli dokonuje się rocznych spłat tej samej pożyczki, to stopa wynosi 12%, a liczba_rat 4.

 

 

 

 

 

 

 

 

 

 

Wykresy

 

 

Dane: wykresy_dane.xls

 

Baza danych

Przykład1:  BazaDanych1.xls

 

 

 

Przykład 2: excel_zarztabdanych1.xls

 

Obliczenia geodezyjne w Excelu

 

OblGeod_1wzory.htm   OblGeod_wzory.xls

OblGeod_Przykl_wzory.xls 

OblGeod_schemat_pelny.htm  OblGeod_schemat_pelny.xls

 

 

Linki: